iq:

Starting from version 2.3.5 RdpGuard supports command line interface to provide you with powerful and flexible interface for automation tasks.

Check out the rdpguard-service-manager.exe tool located in RdpGuard installation folder (usually C:\Program Files (x86)\RdpGuard)

If you start it from the console, you will see the usage information:

  To report ip address: /report address comment
  Example: /report 1.2.3.4 "OurApp brute-force attempt"

  To block ip address: /block address comment
  Example: /block 1.2.3.4 "OurApp brute-force attempt"

  To unblock ip address: /unblock address
  Example: /unblock 1.2.3.4

  To unblock all ip address: /unblock *
  Example: /unblock *

  To list blocked ip addresses: /list
  Example: /list

  To activate license key: /lic YOUR-LICENSE-KEY
  Example: /lic AAAA-BBBB-CCCC-DDDD

  To deactivate license key: /delic
  Example: /delic

  To display whitelist entries: /whitelist list
  Example: /whitelist list

  To add whitelist entry: /whitelist add ip_address_or_range [optional comment]
  Example: /whitelist add 1.1.1.1

  To remove whitelist entry: /whitelist remove ip_address_or_range
  Example: /whitelist remove 192.168.1.1-192.168.1.10

  To put whitelist file: /whitelist put_file whitelist_file
  Example: /whitelist put_file C:\data\whitelist.xml

  To set block method: /set_block_method firewall|ipsec
  Example: /set_block_method firewall

  To get block method: /get_block_method
  Example: /get_block_method

  To get RdpGuard version: /version
  Example: /version

Commands Description

/report address comment - report brute force attempt to RdpGuard, where address - attacker's IP address and the comment - any comment associated with the address. Attacker's IP address will be blocked when the number of attacks will reach the set limit. The limit is configured in Tools, Options, General.

Examples:

>rdpguard-service-manager.exe /report 1.2.3.4 "OurApp brute-force attempt"

>rdpguard-service-manager.exe /report 66.45.34.42 "Script Abuse"

/block address comment - block specified address with the comment using pre-configured blocking method and duration. The blocking method and duration is configured in Tools, Options, General.

Examples:

>rdpguard-service-manager.exe /block 1.2.3.4 "OurApp brute-force attempt"

>rdpguard-service-manager.exe /block 66.45.34.42 "Script Abuse"

/unblock address - unblock specified address. Use the * symbol to unblock all ip addresses.

Examples:

>rdpguard-service-manager.exe /unblock 94.157.98.54

>rdpguard-service-manager.exe /unblock *

/list - get list of blocked ip addresses

Example:

>rdpguard-service-manager.exe /list

5 blocked IP addresses found

[Address]             [Block Date]          [Unblock Date]       [Comment]

27.121.80.0        27.11.2015 17:08:50    28.11.2015 17:08:50    RDP
27.121.80.1        27.11.2015 17:09:14    28.11.2015 17:09:14    RDP
27.121.80.55       27.11.2015 17:09:17    28.11.2015 17:09:17    RDP
43.240.228.4       27.11.2015 17:09:10    28.11.2015 17:09:10    RDP
43.240.228.43      27.11.2015 17:09:21    28.11.2015 17:09:21    RDP

/lic YOUR_LICENSE_KEY - activate license key

Example:

>rdpguard-service-manager.exe /lic AAAA-BBBB-CCCC-DDDD

/delic deactivate license key

Example:

>rdpguard-service-manager.exe /delic

/whitelist list - show whitelist entries

Example:

>rdpguard-service-manager.exe /whitelist list

6 whitelisted IP addresses found

[IP Address or Range]              [Comment]

2.120.0.0-2.127.255.255
2.216.0.0-2.223.255.255
5.2.16.0-5.2.23.255                 comment
5.10.16.0-5.10.31.255
5.10.136.0-5.10.143.255
217.199.176.0-217.199.191.255       comment

/whitelist add ip_address_or_range [optional comment] - Add whitelist entry and optional comment

Example:

>rdpguard-service-manager.exe /add 1.1.1.1
>rdpguard-service-manager.exe /add 1.1.1.1-1.1.1.120
>rdpguard-service-manager.exe /add 2.2.2.2 comment

/whitelist remove ip_address_or_range - Remove whitelist entry

Example:

>rdpguard-service-manager.exe /remove 1.1.1.1
>rdpguard-service-manager.exe /remove 1.1.1.1-1.1.1.120

/whitelist put_file whitelist_file - Replace entire whitelist with new file

Example:

>rdpguard-service-manager.exe /whitelist put_file C:\import\whitelist.xml

/set_block_method firewall|ipsec - set block method - Windows Firewall or IP Security Policies

Example:

>rdpguard-service-manager.exe /set_block_method firewall

/get_block_method - get block method

Example:

>rdpguard-service-manager.exe /get_block_method

/version - returns RdpGuard version

Example:

>rdpguard-service-manager.exe /version