iq:

RdpGuard News

11 Mar, 2020 - RdpGuard Version 6.7.7 Released

  • Improved support for hMailServer SMTP Engine
  • Improved support for MS-Exchange IMAP engine
  • Improved support for FileZilla FTP Server
  • UI improvements and bug-fixes
  • Other internal imrovements and bug-fixes

13 Feb, 2020 - RdpGuard Version 6.6.7 Released

  • Maintenance release
  • Minor imrovements and bug-fixes

23 Jan, 2020 - RdpGuard Version 6.5.9 Released

  • Added support for SMTP user enumeration detection
  • Added support for log based FTP monitoring
  • Memory and CPU usage optimizations
  • Stability improvements and bug-fixes

31 Oct, 2019 - RdpGuard Version 6.3.7 Released

  • Maintenance release
  • Fixed an issue with IP Cloud accessibility on some machines
  • Fixed an issue with MS Exchange monitoring via Application event log

24 Oct, 2019 - RdpGuard Version 6.3.1 Released

  • Fixed an issue with RDP detection engine on Windows Server 2012-2019
  • Fixed an issue with Custom Actions/Notifications
  • Improved support for traffic based IMAP/POP3 detection engines
  • Added support for the %HOSTNAME% custom actions variable
  • Added support for successful login notifications for Windows Server 2003
  • Core stability improvements and bug-fixes
  • UI improvements and bug-fixes

22 Aug, 2019 - RdpGuard Version 6.1.7 Released

  • Maintenance release
  • Minor imrovements and bug-fixes

15 Aug, 2019 - RdpGuard Version 6.1.1 Released

  • Implemented the IP Cloud feature
  • Added support for Geo-IP blocking
  • Optimizations for Windows Firewall (one rule per 1000 addresses now)
  • UI optimized to work with large blocks of IP addresses
  • Max block period is increased to 1 year
  • Improved support for Kerio Connect mail server
  • Added basic support for IBM Domino SMTP server
  • Improved successful login notifications to filter out local processes
  • Support for multiple e-mail recipients for custom actions
  • Improved Custom Actions to allow cmd/bat files execution
  • Custom Actions variable changed from %COMMENT% to %PROTOCOL%
  • Memory optimization for traffic based detection engines
  • Fixed rare service crash on Windows Server 2012-2019
  • Various internal improvements and bug-fixes

28 Aug, 2018 - RdpGuard Version 5.4.9 Released

  • Maintenance release
  • Improved support for RdWeb detection engine
  • Improved support for Kerio mail server
  • Fixed an issue with UI settings saving

18 Jun, 2018 - RdpGuard Version 5.3.5 Released

  • Added support for POP3 Protocol
  • Added support for log-based monitoring for MS-Exchange (IMAP, POP3, SMTP)
  • Other internal improvements and bug-fixes

02 Apr, 2018 - RdpGuard Version 5.2.3 Released

  • Added support for IMAP Protocol
  • UI - added sorting for Blocked IP Addresses table
  • UI - added support for IP Ranges and CIDRs to IP Filtering Dialog
  • Various internal improvements and bug-fixes

14 Mar, 2018 - RdpGuard Version 5.1.1 Released

  • Maintenance release
  • Fixed service crash when using WinPcap monitoring method

12 Mar, 2018 - RdpGuard Version 5.0.9 Released

  • Improved RDP detection engine for Windows Server 2012
  • Improved Whitelist to accept CIDRs
  • Whitelisted IP addresses unblocked automatically now
  • SMTP - improved support for Kerio Connect Mail Server
  • SMTP - improved support for MS Exchange Mail Server
  • Fixed an issue with IP blocking on Windows Server 2003
  • User name detection for MS-SQL and MySQL
  • Other minor improvements and bug-fixes

19 Dec, 2017 - RdpGuard Version 4.8.9 Released

  • Maintenance release
  • Fixed an issue with Raw Sockets monitoring method
  • Fixed an issue with IPSec blocking method
  • Fixed an issue with empty Blocked IPs list in rare cases
  • Other minor improvements and bug-fixes

15 Dec, 2017 - RdpGuard Version 4.8.5 Released

  • Added support for VoIP (SIP Protocol)
  • Improved RDP detection engine for Windows Server 2012
  • Auto-reset counter of failed login attempts if user successfully logged in
  • Added new TOTAL_IP_BLOCKED variable for Custom Actions/Notifications
  • Added User Logged In event for Custom Actions/Notifications
  • MS-Exchange SMTP Server moved to SMTP Settings
  • Improved support for Kerio Connect SMTP Server
  • Support for multiple ports for RDP and FTP protocols
  • RdpGuard now works on computers with FIPS compliance enabled
  • Various minor/internal improvements and bug-fixes

22 Jun, 2017 - RdpGuard Version 4.2.5 Released

  • Added support for Custom Actions (Notifications)
  • Improved SMTP detection engine (support for log based detection)
  • Improved Windows Server 2012 engine to optimize resources usage
  • Added WinPcap support for FTP Protocol
  • Added RdWeb settings
  • Minor UI improvements and bug-fixes
  • Various internal improvements and bug-fixes

19 Apr, 2017 - RdpGuard Version 3.7.9 Released

  • Maintenance release
  • Fixed the number of minor bugs

10 Apr, 2017 - RdpGuard Version 3.7.3 Released

  • Added support for Remote Desktop Web Access (RD Web Access)
  • Added support for MS-Exchange
  • Added MS-SQL settings
  • Added support for WinPcap
  • Improved compatability with Windows Server 2012/2016
  • New and improved MySQL Engine
  • UI improvements and optimization
  • Various internal improvements and bug-fixes

30 Dec, 2016 - RdpGuard Version 3.1.7 Released

  • Added Advanced Blocking Settings
  • Added whitelist operations to command line interface
  • Improved support for Windows Firewall
  • Improved support for Windows Server 2008

05 Dec, 2016 - RdpGuard Version 3.0.5 Released

  • Maintenance release
  • Improved support for Windows Server 2012/2016

29 Nov, 2016 - RdpGuard Version 2.9.9 Released

  • Switched to .NET 4.0
  • Added RDP protection settings
  • Improved Windows Server 2012 Detection Engine
  • Improved Whitelist to allow large sets
  • Improved MS-SQL detection engine
  • Improved command line interface to get/set block method
  • Other minor improvements and bug-fixes

27 Sep, 2016 - RdpGuard Version 2.7.7 Released

  • Maintenance release
  • Improved RDP-TLS detection engine for Windows Server 2008 family

05 Sep, 2016 - RdpGuard Version 2.7.1 Released

  • Maintenance release
  • Minor improvements in RDP, FTP, SMTP engines
  • Stability improvements

10 May, 2016 - RdpGuard Version 2.6.3 Released

  • Fixed an issue with RDP engine on Windows Server 2008 family
  • Improved SMTP detection engine (extended SMTP Servers support)
  • Stability improvements
  • Other minor improvements and bug-fixes

25 Feb, 2016 - RdpGuard Version 2.5.1 Released

  • Added support for multiple SMTP ports
  • Fixed an issue with RdpGuard Service crash on some systems
  • Minor improvements and bug-fixes

10 Feb, 2016 - RdpGuard Version 2.4.7 Released

  • Added support for SMTP Protocol
  • Improved support for Windows Server 2012 and Windows Server 2016 (TLS 1.2)
  • Various internal improvements and bug-fixes

27 Nov, 2015 - RdpGuard Version 2.3.5 Released

  • Improved RDP Engine to work with all security layers including SSL (TLS)
  • Improved FTP Engine to work with any FTP Server
  • Added support for command line interface
  • Imroved UI to display the block reason for an each ip address
  • Other internal and UI improvements

10 Jul, 2015 - RdpGuard Version 2.1.3 Released

  • Maintenance release
  • Fixed an issue with RdpGuard installer on x86 systems.

09 Jul, 2015 - RdpGuard Version 2.1.1 Released

  • Added support for MySQL Server Protection
  • Added support for ASP.NET Web Forms Protection
  • Improved the Whitelist feature to allow bulk add of IP addresses
  • Improved MS-SQL Engine to catch more brute-force attempts.
  • Added an ability to enable/disable protection for particular protocols
  • User interface improvements
  • Various internal improvements and bug-fixes

02 Apr, 2014 - RdpGuard Version 1.7.1 Released

  • Maintenance release
  • Minor improvements and bug-fixes

11 Mar, 2014 - RdpGuard Version 1.6.7 Released

  • Added support for Microsoft FTP Service
  • Improved work with IP Security Policies
  • Improved Whitelist dialog to validate IP Addresses
  • Other minor improvements and bug-fixes

10 Feb, 2014 - RdpGuard Version 1.6.1 Released

  • Improved support for Windows Server 2012 R2
  • Improved support for MS-SQL server
  • Improved GUI to work with large lists of IP addresses

30 Oct, 2013 - RdpGuard Version 1.5.7 Released

  • Maintenance release
  • Minor improvements and bug-fixes

06 Oct, 2013 - RdpGuard Version 1.5.3 Released

  • Added support for IP address ranges in Whitelist
  • Improved support for MS-SQL Server 2005
  • Improved support for Windows Server 2003

12 Aug, 2013 - RdpGuard Version 1.4.9 Released

  • Maintenance release
  • Fixed some minor bugs

02 Jul, 2013 - RdpGuard Version 1.4.7 Released

  • Maintenance release
  • Fixed an issue with MS-SQL support
  • Other minor improvements and bug-fixes

15 Jun, 2013 - RdpGuard Version 1.4.5 Released

  • Added support for secure logins on Windows Server 2012
  • Added ability to filter the list of ip addresses

02 May, 2013 - RdpGuard Version 1.4.1 Released

  • Improved support for MSSQL Server
  • Improved IPv6 support
  • Added proxy server configuration
  • Added ability to unban all ip addresses (see the Tools menu)

20 Mar, 2013 - RdpGuard Version 1.3.7 Released

  • Maintenance release
  • Minor improvements and bug-fixes

07 Mar, 2013 - RdpGuard Version 1.3.5 Released

  • Improved support for Windows Server 2003
  • Other minor improvements and bug-fixes

06 Feb, 2013 - RdpGuard Version 1.3.3 Released

  • Maintenance release
  • Minor improvements and bug-fixes

26 Jan, 2013 - RdpGuard Version 1.3.1 Released

  • Added support for Windows Server 2003
  • Added IPv6 support
  • New option to automatically reset IP counters
  • New option to choose blocking method
  • Fixed an issue with service auto-start after reboot
  • Other minor improvements and bug-fixes.

04 Oct, 2012 - RdpGuard Version 1.2.5 Released

  • Added support for MS SQL Server.
  • Other minor improvements and bug-fixes.

09 Jul, 2012 - RdpGuard Version 1.2.3 Released

  • Added ability to manually unban an ip address.
  • Fixed appcrash during installation.
  • Other minor improvements and bug-fixes.

11 Jun, 2012 - RdpGuard Version 1.2.1 Released

  • Added IP Whitelist (now you can protect certain ip addresses from banning).
  • More Precise Windows Firewall Detection.
  • Removed Limitation on Maximal Time to Ban.

23 Apr, 2012 - RdpGuard Version 1.0.1 Released

  • We released the first public version of RdpGuard.

Nov 11, 2011 - The Project Started!

  • The project RdpGuard started.